Plasmacon

Plasma 4 Extensions

Source (link to git-repo or to original if based on someone elses unmodified work): Add the source-code for this project on opencode.net

20
7 .4
Description:

Plasmacon is a terminal emulator based on KDE Konsole technology (uses libkonsolepart).

Requires KDE 4, PyKDE, plasma python script-engine and python-devel packages.

To install:
plasmapkg -i plasmacon.plasmoid

To uninstall:
plasmapkg -r plasmacon.plasmoid
Last changelog:

7 years ago

0.3 (20.09.2012)
- Now it is popup enabled and has transparency support.

0.2.3-r2 (20.10.2010):
- Fixed problem with icons.

0.2.3-r1 (18.09.2009):
- Fixed reset of height and width values after reboot/relogin/readd.

0.2.2 (23.08.2009):
- Issue with closing session in "no tabs" mode was fixed.

0.2.1 (21.08.2009):
- Some fixes and changes with opening new sessions.
- Now the last one session is restarted after closing.

0.2 (31.07.2009):
- Added tabs support.
- Fixed some issues.

0.1.1 (14.07.2009):
- Now plasmoid is deleted when session is closed.

0.1 (08.07.2009):
- Basic functionality - it simply loads libkonsolepart.so :-).
- Plasmacon works normally only in KDE 4.3 at this moment.

H00K

10 years ago

Works now, thanks :]

Report

H00K

10 years ago

Hullo,

could you list which files exactly your script depends on? I'm trying to get it working on Gentoo and there is no "python-devel" package here.

Report

Anywhere

10 years ago

I'd like to again request that, when embedded in a panel, the user have the option of making it a completely embedded console, or have it show as an icon that expands to a full console when clicked. (As the calculator plasmoid in KDE 4.4 does.)

Great Plasmoid and thanks a lot!

Report

SilvaRizla

10 years ago

This is a great little plasmoid, but is still being let down by transparency. Is transparency being worked on at the moment?

Report

zuargo

10 years ago

The problem was in the KDemod 4.3.1 arhclinux's packages, actualizing the system to 4.3.2 the error is fixed

Related:

http://bbs.archlinux.org/viewtopic.php?pid=633527

http://chakra-project.org/bbs/viewtopic.php?pid=9591

Thanks :)

Report

bashboxx58

10 years ago

This plasmoid was devilishly hard to find, without knowing the name. I tried searching google, and i tried the search here. Tried "terminal" asnds "plasmoid", etc. Finally I just went through all the plasmoids page by page.

It could be me. It often it, but how are the tags for this item?

I'm putting it in my deliciopus bookmarks, so I won't have this problem next time, and this incredibly basic plasmoid (Can't believe it's not on every KDE desktop by default!) was worth the search.

Report

C

iduhasti

10 years ago

It is easy to find this plasmoid using KDE's "Get Hot New Stuff" service.

google is not a panacea :)

Report

bashboxx58

10 years ago

It's easy to find that way in KDE4.4, not in 4.3. And more to the point, it was hard to find from this site.

Report

zuargo

10 years ago

ok, I downgrade the pyqt package from the 4.6.0-1 version to the 4.5.4-1 version, this allowed me downgrade the sip package from the 4.9.0-1 version to the 4.8.2-1 version.

The plasmoid worked if I launched it from a terminal using the plasmoidviewer command, but if I launched it graphically (right clic on the desktop > Add graphical elements...), gave the same error "Failed to create a python script engine for the graphic element plasmacon".

Then I restarted the system and could launch Plasmacon of both ways.

Maybe I must report all this as a bug in the archlinux's bugtracker, what do you think?

Report

zuargo

10 years ago

thanks so much :)

Report

zuargo

10 years ago

Thanks so much for your work.

I have a question, hopefully, you can help me, in archlinux what packages contains: pykde, plasma python script-engine and python-devel?

I can install this plamoid but it does not works, when I launch it says this: "Failed to create a python script engine for the graphic element plasmacon"

Thanks in advance

Report

C

iduhasti

10 years ago

Quote:I have a question, hopefully, you can help me, in archlinux what packages contains: pykde, plasma python script-engine and python-devel?

No, I don't know. I never used archlinux.

Quote:I can install this plamoid but it does not works, when I launch it says this: "Failed to create a python script engine for the graphic element plasmacon"

Try to launch plasmoid with "plasmoidviewer Plasmacon" from console and post the result here.

Report

zuargo

10 years ago

Here the terminal output:

Traceback (most recent call last):
File "/usr/share/apps/plasma_scriptengine_python/pyappletscript.py", line 21, in <module>
from PyKDE4.plasma import Plasma
RuntimeError: the sip module implements API v6.0 but the PyKDE4.plasma module requires API v5.0

Report

C

iduhasti

10 years ago

thanks, I have found this (http://bbs.archlinux.org/viewtopic.php?pid=632942 )discussion about (I think) the same problem. As I understand, the decision is in downgrading sip package.

Report

canolucas

10 years ago

for the translucency issue, i think you have to add:

setAttribute(Qt.WA_NoSystemBackground, True)
setAttribute(Qt.WA_TranslucentBackground, True)

to the Qwidget, but anyways i dont know if this will work, because python bindings were built for qt 4.4, and semi transparent qwidgets were introduced in 4.5. so the solution would be to port everything to c++ or wait for the PyQt update.

Report

C

iduhasti

10 years ago

Quote:so the solution would be to port everything to c++

I thought about this solution too, but I can not to do it now due to lack of time. Maybe 2 or 3 weeks later I'll experiment with porting :)

Report

eqisow

10 years ago

Transparency doesn't seem to work in plasmacon. It would be very nice if it did.

http://imagebin.ca/view/Fy35PP6.html

Report

Anywhere

10 years ago

One option that would be nice (especially if embedded in a taskbar) would be if it normally displayed as a thumbnail, then expanded when clicked. A console 'gadget' for Win7 behaves this way, and it would be a nice option for this.

Anyone disagree?

Report

MiCap

10 years ago

Now the dimensions seems to be fixed, but I noticed that the dimensions values are common for all instances of plasmacon. So is not possible to have multiple plasmacon widgets with different dimensions. Am I right about that?
This widget is very useful. Keep the good working!

Report

C

iduhasti

10 years ago

Quote:Am I right about that?

Yes

Report

M3t4linux

10 years ago

I've installer this plasmoid, but I encounter an error message :"Failed to install Script"

My OS is a Debian sid and I've installed :
Python-dev
Python-kde4
Python-kde4-dev
Plasma-scriptengine-python

Why this error message please?

A french user

Report

C

iduhasti

10 years ago

Possibly, the problem is in python 2.5, that is default for debian sid. I use python 2.6 in gentoo.

Try to change line 77 in ~/.kde4/share/apps/plasma/plasmoids/Plasmacon/contents/code/main.py file:

from "except ValueError as e:"
to "except ValueError, e:".

It works for my debian sid.

Report

M3t4linux

10 years ago

Thanks you very much, it works perfectly now!!

Report

MiCap

11 years ago

The reset of height and width values is not completely corrected.
It saves the width but not the height. Try to make your Plasmacon beeing the same size of your desktop and then tell me if it works well for you.
I have the plasma option "Different activity for each desktop" enabled. Don't know if it could be related or not.

Report

XxtjaxX

11 years ago

I don't know if that is possible in python or not. Specially PyKDE. But you maybe could change the Plasma::Applet into a Plasma::PopupApplet because that would be very cool. This way you can move it to a panelbar and pop it up if needed.
If this is possible to be safe check that there is a icon set for the PopupApplet

Report

7 years ago

0.3 (20.09.2012)
- Now it is popup enabled and has transparency support.

0.2.3-r2 (20.10.2010):
- Fixed problem with icons.

0.2.3-r1 (18.09.2009):
- Fixed reset of height and width values after reboot/relogin/readd.

0.2.2 (23.08.2009):
- Issue with closing session in "no tabs" mode was fixed.

0.2.1 (21.08.2009):
- Some fixes and changes with opening new sessions.
- Now the last one session is restarted after closing.

0.2 (31.07.2009):
- Added tabs support.
- Fixed some issues.

0.1.1 (14.07.2009):
- Now plasmoid is deleted when session is closed.

0.1 (08.07.2009):
- Basic functionality - it simply loads libkonsolepart.so :-).
- Plasmacon works normally only in KDE 4.3 at this moment.

12345678910
829
product-maker lionhater Mar 30 2014 9 excellent
product-maker arcanis Mar 03 2014 9 excellent
product-maker LeifErikson May 29 2013 9 excellent
product-maker Contrast Dec 22 2012 9 excellent
product-maker abatyche1x Oct 04 2012 3 bad
product-maker yhmfyhhcf Oct 04 2012 3 bad
product-maker jimmy600 Oct 03 2012 3 bad
product-maker ZaWertun Sep 26 2012 9 excellent
product-maker Grobelard Sep 25 2012 9 excellent
product-maker maajidshah Sep 22 2012 9 excellent
product-maker vitoubien Sep 21 2012 9 excellent
product-maker KingSphinx Sep 20 2012 9 excellent
product-maker tobaj Dec 05 2011 9 excellent
product-maker Lugian Oct 12 2011 9 excellent
product-maker vbachtold Sep 11 2011 9 excellent
product-maker DavidEdmundson Sep 07 2011 9 excellent
product-maker dentharg Sep 01 2011 9 excellent
product-maker midutz21 Aug 21 2011 9 excellent
product-maker dingsas Aug 11 2011 9 excellent
product-maker Quintasan1 Jun 22 2011 9 excellent
product-maker kutzmann Jun 18 2011 9 excellent
product-maker rwklarin Jun 16 2011 9 excellent
product-maker tcat Jun 15 2011 9 excellent
product-maker kem May 23 2011 9 excellent
product-maker fineday2love May 05 2011 9 excellent
product-maker Brutus180 Apr 25 2011 9 excellent
product-maker oywjun Apr 03 2011 9 excellent
product-maker palacio Mar 10 2011 9 excellent
product-maker supermadman Jan 24 2011 3 bad
product-maker ZLv Jan 23 2011 9 excellent
product-maker m4ktub Jan 22 2011 3 bad
product-maker jdalt Nov 25 2010 3 bad
product-maker aspotashev Nov 19 2010 9 excellent
product-maker pejakm Nov 06 2010 9 excellent
product-maker deabru Oct 22 2010 9 excellent
product-maker Tids Oct 21 2010 3 bad
product-maker Montse Oct 15 2010 3 bad
product-maker Base: 4 x 5.0 Ratings
Be the first to comment
arcanis
Mar 03 2014
LeifErikson
May 29 2013
swarfega
Jan 04 2013
damianatorrpm
Sep 26 2012
Grobelard
Sep 25 2012
opaflamme
Sep 22 2012
tobaj
Dec 05 2011
Muhlemmer
Apr 13 2011
janet
Feb 10 2011
aspotashev
Nov 19 2010
lollypop
May 17 2010
bashboxx58
Apr 20 2010
DrDran
Mar 07 2010
Czessi
Sep 25 2009
infernalroot
Sep 15 2009
bobcollard
Aug 29 2009
SoundreameR
Aug 24 2009
Montblanc
Aug 23 2009
CyberTribe
Aug 02 2009
Emdek
Jul 14 2009
File (click to download) Version Description Downloads Date Filesize DL OCS-Install MD5SUM
*Needs pling-store or ocs-url to install things
Pling
0 Affiliates
Details
license
version
0.3
updated Sep 20 2012
added Jul 08 2009
downloads 24h
0
mediaviews 24h 0
pageviews 24h 11