Debian woody package of SuperKaramba

Karamba & Superkaramba

Source (link to git-repo or to original if based on someone elses unmodified work): Add the source-code for this project on opencode.net

0
5.0
Description:

This package was made for debian woody and the kde 3.1 packages from downloads.kde.org... maybe it will work on sarge too (it do not work on Sid, superkaramba is already on sid)

Many Thanks to Herv
Last changelog:

17 years ago

0.33-1
* New upstream release

moto

18 years ago

hi vslick ,

Would you mind to rebuild the 0.24 version of superkaramba. I find there are so many themes will be got core dump by using 0.23.

Or would you give the debian package sources of superkaramba. I can rebuild it and put it on my web site. Thank you so much. :-)

Report

moto

18 years ago

I use debian sid ( unstable ). When I download this pacakge and install it by using dpkg -i 5878-superkaramba_0.22b-woody-1_i386.deb then I got the below error message:

root@debian[/tmp]$ dpkg -i 5878-superkaramba_0.22b-woody-1_i386.deb
Selecting previously deselected package superkaramba.
(Reading database ... 127430 files and directories currently installed.)
Unpacking superkaramba (from 5878-superkaramba_0.22b-woody-1_i386.deb) ...
dpkg: dependency problems prevent configuration of superkaramba:
superkaramba depends on libfam0; however:
Package libfam0 is not installed.
superkaramba depends on libqt3-mt (>= 3:3.1.2); however:
Package libqt3-mt is not installed.
superkaramba depends on python2.1; however:
Package python2.1 is not installed.
dpkg: error processing superkaramba (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
superkaramba

That's too bad! I really want to use superkaramba. This is great ! Would you help me to rebuild deb package for debian sid. Thank you very much !

Report

moto

18 years ago

Sorry~~~~~~

I find the solution above ...

Sorry ! Please forgive me. :-P

Report

vslick

18 years ago

as i posted in the actual super karamba thread accidentally ( hey its 4:37 im allowed to make mistakes :)

ive compiled a debian unstable package of 0.2.2, test it out see if it works for you. it installed fine for me no probs.

the link to download is:

http://www.vnet.ndirect.co.uk/superkaramba_0.22-1_i386.deb

this should work with debian unstable only. so be warned if your using woody or sarge dont use this package.

Report

roullian

18 years ago

Thanx, it's working fine on my Debian sid! The only little trouble is that it does not install if the official unstable karamba is already installed - but it can be removed anyway, there's no need for it if superkaramba is around.

Julien Dubois.

Report

ageitgey

18 years ago

awesome as usual :)

Report

pkalap

18 years ago

Sadly, when I try to install it, dpkg tells me I need libqt3-mt and libfam0 to install superkaramba. But I have libqt3c102-mt and so when I tell apt-get to install libqt3-mt, it asks me if it's ok to remove KDE and libqt3c102-mt and stuff. But it's not ok with me of cource :(
Until recently I was useing Sid, now (after X crash) slowed down to Sarge :)

Report

roullian

18 years ago

Yep, it doesn't work with sid because of libqt3-mt (which has been replaced), and libfam0.
However, karamba itself has already made it to sid, see :
http://packages.debian.org/unstable/kde/karamba.html

So it's time to apt-get :-))

HTH,

Julien Dubois.

Report

C

prichards

18 years ago

I check on debian package list and that package is part of the inestable distribution. Maybe that package wasn't downgrade when you change to sarge.
Well my package was created on woody with the libqt3 and kde3.1.1a packages from download.kde.org, i'm not sure if it will work on the others dist. (i'm almost sure that it will not work on sid).
Maybe you can fix it, instaling the libqt3 and kde packages from that source (or recompiling the package :) )

Report

vslick

18 years ago

it definately doesnt work with debian unstable.. any one done any debian unstable packages for this ?


thanks

v

Report

vick21

18 years ago

Yes it works. What you would have to do is this:
1) Install libqt3-headers,
libqt3-compat-headers, libqt3-mt-dev, libqt3c102 and libqt3c102-mt.
2) install last g++ (apt-get update, apt-get install g++)
3) install python2.1, python2.1-dev
4) export QTDIR=/usr/share/qt3
5) export QMAKESPEC=$QTDIR/mkspecs/linux-g++
6) And install superkaramba.
7) If it does not work to you with this, observes that error gives you to see if we can help you.

Report

b9er

18 years ago

i tried to build the source, but i got an error that suggests i dont have kde headers installed.. i am currently using kde.. and i could't find a package that was specific to kde headers.. any ideas?

error
checking for KDE... configure: error:
in the prefix, you've chosen, are no KDE headers installed. This will fail.
So, check this please and use another prefix!

Report

vslick

18 years ago

vick was going on about compiling it from source not using the .deb that on this page it does compile following vick21's advice.


ive made a .deb for unstable im testing it now, if it installs on then ill make it available. I cant honestly say if it will install on your machine.


arrgh just made the package and its been updated to 0.22 now argh.. ill remake a package. and post here shortly

Report

b9er

18 years ago

I have followed all of those steps.. and verified the packages + exports.. i still get the same error
Unpacking superkaramba (from 5878-superkaramba_0.21-woody-1_i386.deb) ...
dpkg: dependency problems prevent configuration of superkaramba:
superkaramba depends on libfam0; however:
Package libfam0 is not installed.
superkaramba depends on libqt3-mt (>= 3:3.1.2); however:
Package libqt3-mt is not installed.
dpkg: error processing superkaramba (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
superkaramba


is there something i can do to make sure the environment variables are being used.. i verified that the paths specified to exist

Report

vick21

18 years ago

Could you to make a package for Debian PPC?

Report

C

prichards

18 years ago

sorry, but i don't know how.
I'm reading documentation about cross compiling now, i let you know if its work.

I could send you the sources, ready to package... i think that will be easier.

Report

vick21

18 years ago

Send to me the source, but I have a problem with libqt3-mt and I don't know if I will be able to do it :(

Thank you and excuse for my english language but I'm spanish:-)

Report

kinkerlitzchen

18 years ago

Did you compile it using a different Xfree XServer version than the one officially available for Debian Woody? I tried to install your package, but it complained and told me I needed Xfree 4.2. So I compiled it myself using

export KDEDIR=/usr/include/kde && export QTDIR=/usr/share/qt3 && ./configure --prefix=/usr

It worked (after me installing the additional python-dev package) and thanks to checkinstall I have a nice .deb of my own now ;)

kiki

Report

C

prichards

18 years ago

Sorry, my mistake, i didn't note that its depends on xlibs (I had XFree 4.2 on my machine), i have recompiled now, could you please test it and tell me how it works?

Thanks

Report

kinkerlitzchen

18 years ago

As far as I can tell there's no dependency problem anymore.
Plus I tested it with tuxbar, and, yes, it's working well.

thanks

kiki

Report

Ryo99

18 years ago

Dunno why, but last release 0.17H works all the karamba .themes. I'm using Debian Woody R1 with KDE 3.1.1a. Thanks again !

Wonder if you can add a small icon on the K-menu, it doesn't show anyone. Also seems there isn't any documentation under /usr/doc/superkaramba. Keep the great job ! :)

Report

jmk

18 years ago

Hi,

I'm reponsible of karamba into Debian. For the moment I think's that it's not a
good idea to package OFFICIALLY Superkaramba (but thanks for your unofficial package) since I've understand that the author of Superkaramba intend to provide a patch to the karamba author.
As a matter of fact, it will be a good idea not having two softwares !

Report

wheely

18 years ago

I don't agree that these two packages should be merged. Karamba is a nice generic tool that doesn't do too much but does it well and with no fuss and so much flexibility that it can be used for surprisingly complex tasks. SuperKaramba adds all sorts of funky eye-candy but at the expense of the flexibility that karamba has. SuperKaramba's main aim seems to be to produce a OS-X like panel (which it does beautifully) but to me, karamba is not the "tool" that shoul be used for this. Seems to me that SuperKaramba should be merged with kicker, not Karamba.

I think these patches have killed off Karamba.

Report

Tropezone

18 years ago

It's always the same problem in linux, a lot of similar small projects that never will be finished. The way is that superkaramba and karamba becomes the same and not two projects.

Report

C

prichards

18 years ago

I'm agree with you, i never intend that this package become official (that's why i released here, and not send it to debian), i just made this because i saw (on the coments of the superkaramba release) some debian users having troubles compiling superkaramba.
It will be a really good idea that the improvements made on superkarama become a part of the original karamba, and the two authors start to work together in one proyect.

Report

17 years ago

0.33-1
* New upstream release

12345678910
Be the first to comment
File (click to download) Version Description Downloads Date Filesize DL OCS-Install MD5SUM
*Needs pling-store or ocs-url to install things
Pling
0 Affiliates
Details
license
version
0.33-1
updated Oct 21 2003
added Apr 24 2003
downloads 24h
0
mediaviews 24h 0
pageviews 24h 2