graphite

KDE 3.0-3.4 Themes

Source (link to git-repo or to original if based on someone elses unmodified work): Add the source-code for this project on opencode.net

0
5 .0
Description:

this is a style+a window decoration+a color scheme (peviously only a style)
i hope you like it
it looks a little like mac os x but evrithing is flat and it has darker colors

to install just extract and untar evrything, open a terminal cd to the graphite directory and run ./install.sh
but DO NOT RUN install.sh AS ROOT OR IT WILL NOT WORK!

if you want to ask me something or if u have some ideas to implement in newer versions of this thing just email me : my emailadress is kbam@myrealbox.com

please post your comments (and vote)!! :)

if you downloaded your copy before 03/08/2002(DD/MM/YYYY) be sure to download the newest version today!

qze

17 years ago

lol, looks like everybody has got another problem with your style! The Screshots look really
good and I would like to be able to install your style!

Here's what my Console "says" if I run install.sh as a User on my Mandrake 9.0 box:
------------------------------------
[qze@sqrt graphite]$ ./install.sh
installing graphite color scheme...
ok
installing graphite icewm window decoration...
ok
installing graphite style...
ok
running kinstalltheme...
ok
done
[qze@sqrt graphite]$
-----------------------------------
Looks pretty good, doesn't it? The Problem is, nothing happens ;)
So I tried it as root:
----------------------------------
[root@sqrt graphite]# ./install.sh
installing graphite color scheme...
ok
installing graphite icewm window decoration...
ok
installing graphite style...
ok
running kinstalltheme...
DCOPServer up and running.
ok
done
[root@sqrt graphite]# kdeinit: Fatal IO error: client killed
kdeinit: sending SIGHUP to children.
Mutex destroy failure: Device or resource busy
kdeinit: sending SIGTERM to children.
kdeinit: Exit.
----------------------------------
This doesn't look too good!
I also tried to install it the way grandpajive did it on his gentoo box!
......Didn't Work!
The same fault like I got as a root!

So, what can I do? I would really like to install your cool style!

What about making a *.ktheme file? That would be lots easier to install!

So far: Respect for good work and |PEACE! STOP BUSH's WAR!|

Report

qze

17 years ago

Well, that's how I made it run on my Mandrake 9 box:

In console:
tar -xzvf 2621-graphite.tgz
cd graphite
./install.sh
-----------echo =------------------
installing graphite color scheme...
ok
installing graphite icewm window decoration...
ok
installing graphite style...
ok
running kinstalltheme...
ok
done
-----------------------------------
then close the console!
go to the KDE Control Center!
Choose "Appearance & Themes" and Select the graphite Style!
Then choose "Window Decorations" an select "IceWM"!
In the "Configuration [IceWM]"-tab: select graphite!

the background image I couldn't find! I just loaded it down here @ KDE-Look!

Have fun with this Theme!

Report

linuxfond

17 years ago

I treid it both as root and as non root.
If I run it as root I don't get any bad messages. If I run it as non root I get this:

$ ./install.sh
./install.sh: line 6: cd: style: No such file or directory
cp: cannot stat `pixmaps': No such file or directory
cp: cannot stat `themes': No such file or directory
cp: cannot stat `wallpapers': No such file or directory
cp: cannot stat `icewm-themes': No such file or directory
Acqua-Graphite for KDE installed.

Nothing is available in the CC.

Report

linuxfond

17 years ago

The theme is beautiful. Great!
Installation is really easy!
I just run ./install.sh
get messages that all is installed, great!
I go to control center, and find that nothing is available: no style, no theme, no colors, no icons.
My distro is MDK. How do I fix this? I have this problem with all themes, which install using ./install.sh

Report

schmolch

18 years ago

I am so disrupted!!!
The window decoration is nice.
The style is excellent in most parts - if there wouldnt be that one thing which i really hate - the dark background of the icons, i really really hate that.
But i love all the rest!!
Oh im so disrupted.

Report

schmolch

18 years ago

i dont know why, but after a reboot the dark background disappeared. now the background of the icons is the same color than the toolbar-background, which is perfect :)
thx for that great style, and dont worry about the much too low rating this style is awesome.

Report

CoolThemer

18 years ago

Can anyone please show me what in the world is going on? *None* of the styles work. They simply won't appear in KDE's control centre. I tried running their install script, then I tried, ./configure make and make install (those ones that need one), then I've tried moving .themerc in that /usr/share/app/kde/kstyle/themes directory (I think that's the location I don

Report

C

hackr007

18 years ago

have you tried running kinstalltheme (not as root)

Report

Cyyb

18 years ago

but...

that font you are using in the screen shots - well - it's butt ugly.

sorry - had to say something.

Report

skrrytch

18 years ago

I installed it today. It great but need some more tuning here and there. Go on ... :-)

i.e.
The down-arrow on toolbar-buttonswith popup-menue doesnt look good because its raw into the border if the button.

Black line are sometimes doublesized. I think thats because there are two, each from another window element. Possibly you can minimize this effect...

The "line" between widget for resizing them doesn't look nice enough (too wide). Its the same for panelappletts "sidebar". Maybe there is another solution.

The highlight-effect in menues should be the same than on the menubar: a darker gray background.

Checkboxes with a bright blue suqare in it? Mmmh, dont like that so much.

And at last: A fitting color-scheme and window-decoration would be nice.

You see, though your work is great, there is alot to do As always ... :-)

Report

C

hackr007

18 years ago

the checkboxes should be better now
download the newest release (the only one for download now) and give me your feedback

Report

skrrytch

18 years ago

they are great, fantastic ... aehem ... I did them :-)

Report

C

hackr007

18 years ago

forget to look at your user info...
great work!
:)

Report

skrrytch

18 years ago

Uhhh, sorry for so many mistakes. I just woke up :-)

Report

grandpajive

18 years ago

Here's how I got it to work in gentoo:

mkdir /usr/kde/3/share/apps/kstyle/themes/graphite

cp ~/graphite/themes/graphite.themerc /usr/kde/3/share/apps/kstyle/themes

cp ~/graphite/pixmaps -R /usr/kde/3/share/apps/kstyle/themes/graphite

su - [dash is needed]
kinstalltheme

That way all users will be able to use it ;)

btw- nice theme... you planning on making a window decoration to go along with it?

Report

jase71

18 years ago

Installs fine on my Mandrake 8.2 system, as long as I'm not logged in as root.

Looks really good. Been looking for something exactly like this... Thinner borders like someone mentioned would be nice, but I'm going to keep using it even without them.

Thanks a ton. This was the last piece I needed to complete my "perfect" desktop.

Report

skrrytch

18 years ago

No new Theme. An I like graphite but I can't test it.

Report

C

hackr007

18 years ago

have you run the script as root?

Report

skrrytch

18 years ago

DONT RUN THE SCRIPT AS ROOT.

As root you won't find kinstalltheme!

Report

Xanadu

18 years ago

OK, good news / bad news. SuSE 8.0 (I don;'t like SuSE. I like my MDK and Gentoo boxes (especially Gentoo...). ANyway, I should;ve tried it as my user account. I didn't think of that. So I tried it:

palermo@set:/home/palermo/EyeCandy/graphite> ./install.sh
installation succesfully completed


Still, nothing shows up in the options anywhere that it should be.

http://xan.drirc.net/graphite1.png
http://xan.drirc.net/graphite2.png

Report

C

hackr007

18 years ago

wauw now i know why it wasn't working on some systems
thanx
i will modify the installation instructions as soon as possible!

Report

skrrytch

18 years ago

Sorry, but I have the same problem:

./install.sh: kinstalltheme: command not found

It's also SuSE 8.0 with kde 3.0.2, newly installed.

Report

Xanadu

18 years ago

set:/home/palermo/EyeCandy/graphite # ./install.sh
./install.sh: kinstalltheme: command not found
installation succesfully completed


????

Report

C

hackr007

18 years ago

have you properly installed kde3?
is it version 3.0.2 (i tried it with that version and it worked)

Report

Xanadu

18 years ago

SOrry about that. That damn enter key...

SuSE 8.0

Untested on anything else thus far. I'll post back after I test it on my Gentoo and MDK machines.

Report

12345678910
Be the first to comment
File (click to download) Version Description Downloads Date Filesize DL OCS-Install MD5SUM
*Needs pling-store or ocs-url to install things
Pling
0 Affiliates
Details
license
version
updated Aug 03 2002
added Jul 30 2002
downloads 24h
0
mediaviews 24h 0
pageviews 24h 0