Flash Editor

Graphic Apps

Source (link to git-repo or to original if based on someone elses unmodified work): Add the source-code for this project on opencode.net

1
5.3
Available as/for: -
Description:

F4L is an open source development environment for Macromedia Flash, a multi-platform format(swf/svg) widely used for web applications and vector animation. Basically, you can make interactive eye candy for your web site or any other purpose while maintain.

This is the version 0.2.1 of the Flash editor for linux, so it is room for a lot of improvements. We are looking for coders,testers and sponsors to help us with this project. You can help us with ideas, patches, money, documentations&tutorials, graphics&sound.
Additional projects are started:
- f4l- server :XML to SWF or SVG server.
---------------------------------- Please use the forum to propose a name and to submit an logo(icon).

Elv13

14 years ago

use qt3, qt4 seem to fail every time

Report

menace1982

14 years ago

What about Flashed? It comes from Flash + Ed(itor)

Report

sjar

14 years ago

It's good to see it among the alive again. It was such a promissing project with certain impact in the news. I wonder why there was no much afford by others to promote the progress of f4l.
UIRA and f4l could become a dreamteam I think.

Let's see what happens in future.

Report

void

14 years ago

I revieve this error when run 'make':

FSDefineSound.h:140: error: extra qualification ‘transform::FSDefineSound::’ on member ‘FSDefineSound’
make[1]: *** [FSDefineSound.o] Error 1
make[1]: Leaving directory `/home/void/Desktop/f4l-0.2.1/src/flagStonePort/transform-cxx-bsd/transform'
make: *** [sub-src-flagStonePort-transform-cxx-bsd-transform-make_default] Error 2

Any way to fix it?

Report

royqh

14 years ago

in f4l-0.2.1/src/flagStonePort/transform-cxx-bsd/transform/FSDefineSound.h:line 140

change FSDefineSound::FSDefineSound to FSDefineSound

Report

fester777

14 years ago

10x It's work perfectly :)

Report

bluexp

14 years ago

Remove "transform::" from FSDefineSound.h:140 ,save,and try again.

Report

bluexp

14 years ago

This error occures using gcc 4.1.
First find "FSDefineSound.h".
Open it with any text editor.
go to line 140
Find "FSDefineSound::FSDefineSound"
That should be "FSDefineSound"
So remove the first part and save the file.
try to run make again.
goodluck

Report

kde05

14 years ago

Thanks! It's started! :-)

Report

kde05

14 years ago

Halo,

I had the same problem.
where I must remove "transform"?

Report

void

14 years ago

Thx for help but there's no such thing as "transform::" in file FSDefineSound.h
:(

Report

asciiwhite

14 years ago

This is great news, a decent Vector animation suit is something linux has needed for sometime.

Hopefully UIRA and F4L get cracking on something wonderful.


Best of luck.

Report

void

14 years ago

It would be really cool if author include some documentation on how to install it. >:(

Report

comtux

14 years ago

qmake
make
make install

Report

bitcrazy

14 years ago

So, where's the update. This is still the version from last year. Nothing changed, no new features. Absolutely alpha. Just a reminder for a good idea?

Greetings

m0nk

Report

C

zvonSully

14 years ago

Last year was 0.2 ; Now it 0.2.1
F4L will merge to UIRA project(not sure, wainting the author to confirme my mail)

Report

revolutionist

14 years ago

my dreams came true...

Report

obsrv

15 years ago

This project looks dead. There is a lot of bugs since 2005 03 and they ALL are still Open and not assigned :(

Report

argus

15 years ago

excuse me the english..
but i will try to say what i want..
that is all that i was waiting for !
now i can use my Linux all day long..
Tanks !

Report

gohanz

15 years ago

A SlackWare 10.2 TGZ Package is ready to download!!

http://www.slacky.it


http://www.slacky.it/index.php?option=com_remository&Itemid=29&func=fileinfo&filecatid=710&parent=category

Report

probono

15 years ago

klik://f4l for those who prefer to klik :-)

(See http://klik.atekon.de/ or http://www.kde-apps.org/content/show.php?content=12841 for a description of klik)

Report

felipe

15 years ago

thank you

Report

AlexeyK

15 years ago

Could you say how to compile translation into program?
I see that there is not any complete translation but if I'll write one...

Report

miguipda

15 years ago

Hi,

under my kubuntu hoary (5.04) I receive the following errors. Before trying to install f4l I do an update of all my packages. Then I can't upgrade rhose error files.

Then how can I use your so usefull program. I sincerelly need it due to the fact I currently follow a web devlopper courses.

Thanks a lot, have a nice day.

Miguipda ;-)

*************
sudo dpkg -i f4l_0.2-1_i386.deb
Sélection du paquet f4l précédemment désélectionné.
(Lecture de la base de données... 117877 fichiers et répertoires déjà installés. )
Dépaquetage de f4l (à partir de f4l_0.2-1_i386.deb) ...
dpkg : des problèmes de dépendances empêchent la configuration de f4l :
f4l dépend de libc6 (>= 2.3.2.ds1-21) ; cependant :
La version de libc6 sur le système est 2.3.2.ds1-20ubuntu14.
f4l dépend de libgcc1 (>= 1:4.0.0-9) ; cependant :
La version de libgcc1 sur le système est 1:4.0.0-7ubuntu6~5.04ubp1.
f4l dépend de libqt3c102-mt (>= 3:3.3.4) ; cependant :
La version de libqt3c102-mt sur le système est 3:3.3.3-7ubuntu3.
f4l dépend de libqt3c102-mt (>= 3:3.3.4-3) ; cependant :
La version de libqt3c102-mt sur le système est 3:3.3.3-7ubuntu3.
f4l dépend de libfontconfig1 (>= 2.3.0) ; cependant :
La version de libfontconfig1 sur le système est 2.2.3-4ubuntu7.
f4l dépend de libxrender1 (>= 1:0.9.0-2) ; cependant :
La version de libxrender1 sur le système est 0.9.0-0ubuntu4.
f4l dépend de libexpat1 (>= 1.95.8-3) ; cependant :
La version de libexpat1 sur le système est 1.95.8-1.
dpkg : erreur de traitement de f4l (--install) :
problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
f4l

Report

rgfree

15 years ago

How about "levin":

http://tinyurl.com/92c8n

Report

12345678910
11
product-maker poiuztrew Apr 13 2015 3 bad
product-maker nikore90 May 05 2012 9 excellent
Be the first to comment
ngrocott
Dec 09 2009
File (click to download) Version Description PackagetypeArchitectureRelease ChannelDevices Downloads Date Filesize DL OCS-Install MD5SUM
*Needs pling-store or ocs-url to install things
Pling
0 Affiliates
Details
license
version
0.2.1
updated Jun 07 2006
added May 03 2005
downloads 24h
0
mediaviews 24h 0
pageviews 24h 2
System Tags app software