xboxdrv-Qt

Utilities

Source (link to git-repo or to original if based on someone elses unmodified work): Add the source-code for this project on opencode.net

3
7 .2
Description:

xboxdrv-Qt is written in Qt5.6
Please help to test, at the moment it works only for a controller, but it has the same options plus button mapping.

to run in terminal :
Giving permission to execute
chmod +x xboxdrv (Just one time) then
sudo ./xboxdrv

it needs sudo privileges to work and Qt 5.6 installed on your system.
feel confident to report problems to obedlink@gmail.com or leave a comment here.
Last changelog:

xboxdrv-Qt RC 3 years ago

- Support for 4 controllers enabled
- Close to tray/show window through the systray icon context menu
- Ready for use with some small problems that no affect it use. (I'm working on it)

9

LJason77

2 years ago

9 +

Report

9

neonoafs

2 years ago

Even with qt installed, i got these errors:

root@andre-PC ~/Downloads # ./xboxdrv
./xboxdrv: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5' not found (required by ./xboxdrv)
./xboxdrv: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.6' not found (required by ./xboxdrv)
./xboxdrv: /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5: version `Qt_5' not found (required by ./xboxdrv)
./xboxdrv: /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5: version `Qt_5' not found (required by ./xboxdrv)


Report

C

obedlink

2 years ago

You need to have installed a old Qt version, you need at last Qt 5.6

Report

C

obedlink

2 years ago

You need to have installed the Qt libraries, maybe you are using a GTK distribution that not come with Qt libraries.

Report

pollo0012

4 years ago

[2] Cannot load class 'TrayIcon': Unable to load class file.
mainwindow.mainwindow.0

Report

C

obedlink

3 years ago

Hi test the new version written in Qt5 and please help me to report problems, the aplicacion needs to run with sudo in terminal.

Report

haukew

7 years ago

Hi!
I get after installing the .deb this error:

$ xbox360_GUI
ERROR: #2: Cannot load class 'mainwindow': Bytecode too recent. Please upgrade Gambas.

I have this gambas-software installed:

gambas3-gb-desktop
gambas3-gb-form
gambas3-gb-gtk
gambas3-gb-gui
gambas3-gb-image
gambas3-gb-qt4
gambas3-gb-qt4-ext
gambas3-gb-settings
gambas3-runtime

Report

C

obedlink

7 years ago

you need the lastest version of Gambas 3

add this ppa https://launchpad.net/~nemh/+archive/gambas3

then
sudo apt-get update
sudo apt-get upgrade

Report

theborg

7 years ago

Hello, your brougt no root for xboxdrv

Add to the /etc/udev/rules.d/90-xbox.rules

ATTRS{idVendor}=="045e", ATTRS{idProduct}=="0291&amp", OWNER:="root", GROUP:="plugdev",MODE:="0664";


see http://www.grautier.com/grautier/archives/115-XBOX-360-RF-Controller-am-PC-Linux-Windows.html

Report

xboxdrv-Qt RC 3 years ago

- Support for 4 controllers enabled
- Close to tray/show window through the systray icon context menu
- Ready for use with some small problems that no affect it use. (I'm working on it)

xboxdrv-Qt beta 2 3 years ago

- xboxdrv-Qt continues working only for a controller at the moment.
- xboxdrv-Qt start in english if your system language is not spanish.
- If you want you can change the language.
- now you can save a custom configuration file.
- Improvement in button mapping.
- Load of a configuration file is pending.....

xboxdrv-Qt beta 3 years ago

Application rewritten now in Qt5.6
At the moment it only works with a control.
Please help to test and report.

xboxdrv-gui written in gambas (deprecated) 3 years ago

Spanish:
*Paquete GTK disponibles
*Corrección de varios errores y mejoras en la traducción.
*configuración de la velocidad de force-feedback en cada motor.

*Configurar la zona muerta en cada stick

*Configurar los Gatillos como botones

*Configurar el tipo de control a usar.

Por favor reportar cualquier bug o error en la aplicación

English:
*fixes many bugs and translated into english at 100%
*GTK packages availables
*Set the force-feedback speed of each motor
*Set the dead zone of each stick

*Set triggers as button

*Set the Control Type to use.

Please report any bug o error in the application.

12345678910
5
product-maker LJason77 Jul 25 2018 9 excellent
+
product-maker neonoafs Sep 10 2017 9 excellent
product-maker Contrast Jul 30 2013 9 excellent
product-maker baltolkien Apr 09 2013 9 excellent
product-maker unikum111 Apr 04 2013 9 excellent
product-maker Base: 4 x 5.0 Ratings
Be the first to comment
LJason77
Jul 25 2018
Montblanc
Jun 23 2013
baltolkien
Apr 09 2013
File (click to download) Version Description PackagetypeArchitectureRelease Channel Downloads Date Filesize DL OCS-Install MD5SUM
*Needs pling-store or ocs-url to install things
Pling
0 Affiliates
Details
license
version
RC
updated Feb 27 2018
added Apr 04 2013
downloads 24h
0
mediaviews 24h 0
pageviews 24h 0