2ManDVD

Utilities

Source (link to git-repo or to original if based on someone elses unmodified work): Add the source-code for this project on opencode.net

42
7.2
Available as/for: -
Description:

DVD AUthoring tool
Depends :

QT4.6
ffmpegthumbnailer
ffmpeg
transcode
perl
Sox
Mplayer
Mencoder
dvdauthor
Mjpegtools
Netpbm
mkisofs
XINE (optional)
exif

TO LAUNCH USE : ./2ManDVD -graphicssystem raster
Last changelog:

7 years ago

ATTENTION BIG CHANGES

The biggest change in this release is how you compile / execute the program. These changes have been made to end a number of bugs attributed to improper installation files used by the application.

So after get the source and unpack ... run in console:

qmake or qmake-qt4 2ManDVD.pro 2ManDVD.pro (on fedora)
make

and finally:

sudo make install

And I stress the make install (as root)

Then you can start the application from your main menu (kde & gnome tested)

gaspare66

10 years ago

This happen:
Quote:xxx@sidux-moros:~/Download/2ManDVD$ make
g++ -c -pipe -O2 -Wall -W -D_REENTRANT -DQT_NO_DEBUG -DQT_WEBKIT_LIB -DQT_OPENGL_LIB -DQT_GUI_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/share/qt4/mkspecs/linux-g++ -I. -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtGui -I/usr/include/qt4/QtOpenGL -I/usr/include/qt4/QtWebKit -I/usr/include/qt4 -I/usr/lib -I/usr/X11R6/include -I. -I. -o main.o main.cpp
In file included from mainfrm.h:25,
from main.cpp:2:
tetrahedron.h:4:21: error: QGLWidget: No such file or directory
In file included from mainfrm.h:25,
from main.cpp:2:
tetrahedron.h:10: error: expected class-name before ‘{’ token
tetrahedron.h:35: error: ‘GLfloat’ does not name a type
tetrahedron.h:37: error: ‘GLfloat’ does not name a type
tetrahedron.h:82: error: ‘GLuint’ does not name a type
tetrahedron.h:83: error: ‘GLuint’ does not name a type
tetrahedron.h:109: error: ISO C++ forbids declaration of ‘GLUquadricObj’ with no type
tetrahedron.h:109: error: expected ‘;’ before ‘*’ token
make: *** [main.o] Error 1
My error or bug?
Thanks, Gaspare.

Report

gaspare66

10 years ago

.... Same error with 1.4.2 .....

Report

Zizo

10 years ago

Hello, you need to have qt-opengl installed in your system.

Report

gaspare66

10 years ago

Thanks,
I have installed qt-opengl but I haven't
qt4-dev-tools .......
I solve with your help, thanks.













Report

NADOR

10 years ago

WARNING: Failure to find: diapoeditor.h
potential duplicate alias detected: 'execute.png'
potential duplicate alias detected: 'son.png'
potential duplicate alias detected: 'media3.png'

i've got this error after qmake-qt4 2ManDVD.pro

any ideas??

thanks

Report

C

csgib

10 years ago

It's just warning ... no problem for running app.

Report

olegue

10 years ago

On SuSE 11.3 x 64 I have compiled the last version 1.4. I like the slideshow option, it render the pics and slides and process always passes smooth but always produces black clips. I checked with single and multiple pics , render them as mpeg 2, web or mpeg 4 - the result is always a black clip .Mpeg2 and Web give clips with length depending on number of pics, but Mpeg4 HD renders in 0 kB files.

Are there some adjustments I have to make before rendering to avoid the black clip results ?

Report

gaspare66

10 years ago

Slideshow don't work anymore.....

Report

gaspare66

10 years ago

Ever problem in HD format, also in 1.5 2ManDVD produces a file .mpeg 0 mega.
Please where is log file?
Regards,
Gaspare.

Report

9

t3ddy

10 years ago

What package do you mean exactly?

Report

9

t3ddy

10 years ago

Ok, I've found it :)

Report

rustylemur

10 years ago

Thank you for this software! It is amazing, and it does nearly everything I want it to do. Only, it's not making the animated background on the menu properly, or at all. It's just a still image of random colored horizontal lines (not the slideshow of people it's supposed to be), but the text for the buttons are still visible and I can still select them and play the movies. Is there something I can do to isolate the problem?

The file that I'm trying to use is a .mpg file that is 28 seconds long.

Thanks

Report

rustylemur

10 years ago

Well, I got the background to cycle through the pictures properly now, but it doesn't loop back through after it gets to the end. I've checked the box that says "Loop video background" from the Menu parameters, but it still doesn't work.

Any ideas?

Report

TanarRi

10 years ago

When I add a picture to a button the button is not sized to the width+height of the imported picture.
it is also not possible to resize the button by mouse to the height i want - i want the width 297px - but only 296 and 300 is possible.
it would be helpful to have:
a) function like "set the size of the button to the size of the imported button-picture"
b) to set the size of a button my edit the width and height with the keyboard

BTW: Great program!!!!


Greetings
Eugen

Report

horsthilft

10 years ago

The jpegtopnm dependency error in 1.3.3 is gone if I have NO file called "test" in my working directory (users-home).

Report

Delporte

10 years ago

Hey, just compiled this today but wasn't sure where to file bugs/problems. I compiled 1.3.5 but all I would get is an empty dialogue box after choosing the initial working directory. command line output:

$ 2mandvd
LOCALE : "en" /usr/share/2mandvd/
"ERROR OPENING MEDIA IN : /home/<username>/Video/2mandvd"

I compiled 1.3.3 and it works just fine with the exception of a dependency error--it doesn't think I have jpegtopnm installed, but I do. Doesn't seem to affect anything. I'll use 1.3.3 and see how it does, just wanted to let the dev know. Not sure if its a common problem or not, google didn't come up with anything.

Other then that, looks great. Can't wait to burn some DVD's

Report

Zizo

10 years ago

http://bugs.gentoo.org/show_bug.cgi?id=341775

Report

Delporte

10 years ago

Awesome Zizo, works like a champ. I thought it might have been something with the patch and/or sed portions of the original ebuild, but not knowing much about ebuild syntax or sed, I wasn't sure how to fix so thanks for your help in this, it's much appreciated.

Report

horsthilft

10 years ago

Same here with gentoo:

# 2mandvd
LOCALE : "de" /usr/share/2mandvd/
"ERROR OPENING MEDIA IN : /DATEN/VIDEO"



empty dialogue box after choosing the initial working directory

1.3.3 works

Regards

Stephan

Report

Delporte

10 years ago

So I just came to apologize for my original post. I don't think this is necessarily a problem with 2mandvd itself. Originally I was running 1.3.5 on a 32 bit system with the error from my OP and on a 64 bit system with no errors at all. I had to downgrade to 1.3.3 to get a working 2mandvd on my 32 bit machine. Now nothing above 1.3.3 will work on either my 32 bit setup of my 64 bit setup, I get the error from my OP on both, even with 1.4. This is after a recent system update (both are running gentoo). So if the author has any clues as to which dependency might be causing the issue, please let us know, but if no one else is experiencing this then it may be a gentoo specific bug. Again, sorry for the premature bug report but it would be great to get this fixed if the author has any ideas. Thanks for all your hard work. FYI:

QT = 4.6.3 | QT-webkit = 4.6.3-r1 | ffmpegthumbnailer = 2.0.2 | ffmpeg = 0.6 | transcode = 1.1.5-r2 | perl = 5.8.8 | Sox = 14.3.0 | Mplayer = 1.0_rc4 | Mencoder = (same as mplayer) | dvdauthor = 0.6.14 | Mjpegtools = 1.9.0-r1 | Netpbm = 10.49.00 | mkisofs = 3.0.0 | XINE = 1.1.18.1 | exif = 0.6.19

Report

horsthilft

10 years ago

I tried 1.4 in my 64-bit gentoo but the same Problem ...

BUT: If I open a File with 2mandvd (created with 1.3.3 - Nautilus open file with ...) it works - but only in french.

LINGUAS="de -en -he -it -pl -pt -ru

--> LOCALE : "de" /usr/share/2mandvd/
ERROR LOADING ENGLISH LANGUAGE
"ERROR OPENING MEDIA IN : /VIDEO/test"

Has someone istalled it "by hand" on gentoo?

Regards
HORSTHILFT


Report

Delporte

10 years ago

Hmmmm.....
So I downloaded the source and compiled it manually. AFAIK there doesn't seam to be anyway to do a 'make install' in the traditional sense as I got a make: Nothing to be done for `install' error. I'm not that familiar with qmake so there could be some other method for doing a regular system-wide install. Anyway, I just ran it from the directory that I compiled it in with both the recommended method of ./2ManDVD -graphicssystem raster and with just ./2ManDVD and both worked without error. So if you don't mind running it from within whatever directory you choose to compile it in, then I would recommend downloading the source and compiling it yourself. If I get any time maybe I'll try and figure out what gentoo's portage system is doing to the source that is causing the errors. I'm hesitant to file a bug with gentoo as I'm actually running Gnome and only have the QT bits needed to run this application, scribus and digikam so a bug will probably be marked as INVALID pretty quickly. Any of you other gentoo users that are getting this error running a full KDE environment? If so, maybe one of you can drop a bug report and see what the gentoo devs think.

One last note: I got the same error as NADOR when compiling the 1.4 source manually. Doesn't seem to cause any issues. I tried to do a google search for that header file but didn't come up with much.

Regards

Report

Zizo

10 years ago

http://bugs.gentoo.org/show_bug.cgi?id=341775

Report

horsthilft

10 years ago

AHHH sorry I'm on GNOME too - somebody else
there to open a bug?

Report

Delporte

10 years ago

Dunno if it matters but I installed 1.3.5 on a machine running 64 bit gentoo and it runs fine. The problem from my original post was on a 32 bit gentoo system.

Report

7 years ago

ATTENTION BIG CHANGES

The biggest change in this release is how you compile / execute the program. These changes have been made to end a number of bugs attributed to improper installation files used by the application.

So after get the source and unpack ... run in console:

qmake or qmake-qt4 2ManDVD.pro 2ManDVD.pro (on fedora)
make

and finally:

sudo make install

And I stress the make install (as root)

Then you can start the application from your main menu (kde & gnome tested)

12345678910
416
product-maker Cochise May 13 2018 3 bad
product-maker fracaburda Apr 10 2015 3 bad
product-maker mea5 Nov 05 2013 3 bad
product-maker infinity3000 Jun 28 2012 9 excellent
product-maker FraMari Jun 02 2012 9 excellent
product-maker reiniger May 30 2012 9 excellent
product-maker cjann Dec 28 2011 9 excellent
product-maker cochisepoeta Sep 11 2011 9 excellent
product-maker sosonok Jul 30 2011 3 bad
product-maker supportfsf Apr 08 2011 9 excellent
product-maker alltiptop Apr 01 2011 9 excellent
product-maker kaywarrie Mar 31 2011 9 excellent
product-maker axlrose1112 Feb 17 2011 9 excellent
product-maker 1antares1 Dec 13 2010 9 excellent
product-maker gohanz Dec 12 2010 9 excellent
product-maker bugmenot1234 Nov 05 2010 9 excellent
product-maker t3ddy Nov 04 2010 9 excellent
product-maker kmare Oct 16 2010 9 excellent
product-maker sefran Oct 15 2010 9 excellent
product-maker MichauSm Oct 01 2010 9 excellent
Be the first to comment
blanco199
Oct 12 2019
opaflamme
Mar 18 2013
cjann
Dec 28 2011
olegue
Oct 06 2010
amair
Oct 06 2010
horsthilft
Sep 13 2010
Keidon
May 29 2010
kudlaty
May 15 2010
AndreAPL
May 09 2010
vnu007dl
Feb 28 2010
nferenc
Feb 24 2010
t3ddy
Feb 12 2010
usrkl
Nov 12 2009
alexandre
Oct 13 2009
pelouse
Sep 07 2009
ofir
Sep 05 2009
NADOR
Aug 18 2009
squidy
Aug 10 2009
yacup
Aug 04 2009
vagskarm
Jun 26 2009
takedown
Jun 23 2009
samheg
Jun 06 2009
poeschi
Jun 04 2009
nedi24
May 30 2009
linuxcolor
May 04 2009
sya54M
May 04 2009
vinca
May 03 2009
jboss1995
Apr 29 2009
axlrose1112
Apr 09 2009
moostik
Apr 07 2009
gaspare66
Apr 06 2009
Lole
Apr 03 2009
Montblanc
Mar 27 2009
dietermz
Mar 24 2009
Vndecid
Mar 22 2009
Xentrix
Mar 18 2009
painkiller101
Mar 15 2009
dscheapel
Mar 12 2009
Botafoguense
Mar 10 2009
cornbread
Mar 09 2009
Znurre
Feb 22 2009
brdn25
Feb 18 2009
File (click to download) Version Description PackagetypeArchitectureRelease ChannelDevices Downloads Date Filesize DL OCS-Install MD5SUM
*Needs pling-store or ocs-url to install things
Pling
0 Affiliates
Details
license
version
1.8.5
updated Jul 30 2013
added Feb 15 2009
downloads 24h
0
mediaviews 24h 0
pageviews 24h 0
System Tags app software