Progress (Saves Your Progress)

VLC Extensions

Source:

0
Score 50%
Description:

*Resumes automatically playback positions of files.
*Restores playlist items of last session if current playlist is empty.
*Starts last played file when activated (autostart-pause and deactivation of this feature is also possible by tweaking).

Usage:
Activate "Progress" under View in the menu bar.


Installation:
Save the source in the file progress.lua in the following folder (create it if necessary):
*Windows7
**current user
%AppData%\vlc\lua\extensions\
**all users
your-VLC-installation-directory\lua\extensions\
*Ubuntu
**current user
~/.local/share/vlc/lua/extensions/
**all users
/usr/share/vlc/lua/extensions/
Then, restart vlc.

Tested only on Ubuntu with vlc 2.1.2
Known bugs:
*Functionality might be truncated if the default path to the database file contains exotic characters.
**Perhaps, this can be cured by setting DATA_FD (at the top of the script!) to a path (pointing to an existing directory with correct permissions) not containing exotic characters, e.g. DATA_FD = "c:\\bla" (\\ will be interpreted as \).

samantavandeville547241

21 days ago

in fact you must downgrade to VLC Media Player 2.2.8 (64-bit)...

Report

C

roland1

20 days ago

Thanks for reporting. The related documention (for vlc lua extionsion) does not indicate a breaking change. I have just asked in the forum for help, but don't hold your breath.

Report

samantavandeville547241

21 days ago

Don't work on vlc release 3.0.2 please update it's usefull addon.

Report

dihard

3 years ago

It doesn't seem to be loading my video file to the previous playback position on 2.1.4 and osx. It does load the last played file into the playlist when I click the extension. But when I start playing it back it just starts from the beginning. Am I doing something wrong?

Report

C

roland1

3 years ago

Probably, You do nothing wrong, but, I cannot reproduce the bug here (I am not on osx though).
Even the playback should start automaticly after activating Progress, so, it could be an encoding problem (first guess).
More information could help, so maybe you could answer some questions:
- Populate the playlist with two or more files.
- Activate Progress.
- Change playing positions and tracks. Q1: Does Progress resume positions?
- Deactivate Progress.
- Clear Playlist.
- Activate Progress. Q2: Does Progress populate the playlist correctly?
Q3: What is the locale of your machine?
Also, I invite You to visit the forum thread
https://forum.videolan.org/viewtopic.php?f=29&t=119395&sid=6bd99bbd1d9bf1de173ac19bfc1fe55d
(registration is painless)
Best Regards

Report

C

roland1

3 years ago

Uhm, maybe this link is better:
https://forum.videolan.org/viewtopic.php?f=29&t=119395

Report

product-maker 6 6

File (click to download) Version Description Packagetype Architecture Downloads Date Filesize DL OCS-Install
Pling me
Details
license
version
updated May 12 2014
added May 12 2014
downloads today
0
page views today 5
System Tags addon