Previewer

Plasma 4 Extensions

Source (link to git-repo or to original if based on someone elses unmodified work): Add the source-code for this project on opencode.net

1
5 .0
Description:

Just a simple previewer applet which uses KPart to preview the files you drop on.
Last changelog:

12 years ago

added License Headers

DaiVied

10 years ago

such a feature would be so cool! If it could view everything this would be a huge sucess for KDE

Report

swizec

12 years ago

Hi, this works great for text files, but it'd be really awesome if it worked for other stuff like images and pdf's. Or is it just me aching for something like that?

Report

warezmen

12 years ago


i add you plasmoid on my debian repo

deb http://www.amarok2deb.co.cc/debian/ unstable main

Report

buschmann23

12 years ago

You can find my packages for openSUSE here:

http://software.opensuse.org/search?baseproject=ALL&p=1&q=kde4-plasmoid-previewer

Report

joth666

12 years ago

First, nice and useful little addition :)

Just two questions...

1. Is it normal to get a "Qt subapplication" window (mostly just the window titlebar really) when you use the preview with images? Really annoying though.

2. Would it be possible to have the icon to NOT have a black border around the paper? Minor thing, I know, but I prefer when things blend into the rest of my desktop.

Report

C

alediaferia

12 years ago

1. Qt subapplication appears because of the fact that my plasmoid uses KParts.. Maybe Image-Previewing-Part (guess Gwenview) offers that tool to zoom in/out. Btw I'll investigate to see whether is possible to remove or not... or make it optional.

2. I don't think i got what you said. Which border are you talking about? Previewer Icon has no border for me. Please be more precise.

Cheers =)

Report

joth666

12 years ago

Well, I'm not sure exactly how to describe it. It's more evident when using certain wallpapers (and, I would guess, depending on what plamsa theme you're using).

I'll try though. Surrounding the paper-and-the-magnifying glass I at least get a somewhat blackish looking frame. It's not black as I first thought though. It was just the wallpaper I was using that made it look like that. It is sort of semi-transparant. You can see the wallpaper through it (especially if you enlarge the plasmoid quite a bit) but it is still rather noticable. I can maybe fix that myself if I knew which file it is using for the background...it's not widets/background.svg in a theme-directory is it? If it was the background should be completely invisible using my theme (a modified glassified).

Note: I didn't compile from source. I am using a unofficial rpm from the OpenSuse 11 factory repos.

Oh, and I noticed something else too. Maybe just my setup though...the plasmoid remembers its location between sessions but not its size. Whenever I want to use it after logging in, I need to resize it if I want to see what I'm doing.

Report

C

alediaferia

12 years ago

I'm still developing it so it does not support saving settings now.. Hope to provide soon.. Btw I think images say more than thousand words =) =) Then please send me an email enlighting the border (or whatever) in an image.. I'll be happy to check it out =)

Regards

Report

jamboarder

12 years ago

It's really nice to see these great creative ideas coming out.

Report

mherbert

12 years ago

wow nice, just drop it on the previewer and you know what's in there... and the scaling function for images is also good..
thanks

Report

C

alediaferia

12 years ago

Thank you for your comment =) hope you tried the resize feature scrolling your mouse weel over the dialog..

Report

mherbert

12 years ago

Yes I have seen it :) good idea...
But am I the only one who gets some crazy artifacts when I resize the dialog?
I don't know if it's a problem of KWin, my nvidiadriver or what else, I have the same problems with the plasma dialog in my plasmoid....

Report

C

alediaferia

12 years ago

Happens here too. I've an nvidia card + composite enabled. I'll investigate. Thanks for the report


Regards =)

Report

mherbert

12 years ago

I switched the compositing type from "OpenGL" to "XRender" and the problem is gone...

Report

joth666

12 years ago

Sounds like an nvidia issue then. I have the same symptom here, although it only happens if I resize several steps too quickly. One step at a time and I get no artefacts.

Nvidia-driver 173.14, Nvidias own OpenSuse 11 repo. Maybe the same reason why I get borders around things in the system-tray?

Report

mherbert

12 years ago

could you drop me a message when you got a solution for this? I would be very interested ;)

Report

DanaKil

12 years ago

I don't know if it is a problem with my installation but I can't unzip this file (with Ark from KDE 3.5)

I have bzip2 and all, I can see the content of the archive but I have a message "...is not a bzip2 file"

Report

C

alediaferia

12 years ago

Thanks for your report. Now it should work.. =)

Report

12 years ago

added License Headers

12345678910
product-maker Base: 4 x 5.0 Ratings
Be the first to comment
DaiVied
Dec 19 2009
File (click to download) Version Description Downloads Date Filesize DL OCS-Install MD5SUM
*Needs pling-store or ocs-url to install things
Pling
0 Affiliates
Details
license
version
0.1
updated Jul 04 2008
added Jul 02 2008
downloads 24h
0
mediaviews 24h 0
pageviews 24h 0