Image 01
profile-image

diddy1234

R D
test
Liquid Weather ++

Karamba & Superkaramba 1797 comments

by Matti
Score 46.0%
Jun 01 2008
Figured out how to fix it for KDE 4
(google is my friend)

Heres the steps :-

First, make sure you have the package python-qt4 installed.

Using the Add Widgets, select Install from File. Choose SuperKaramba. Click Next and find the lwp-15.0.skz. and Click Finish.

The contents of the skz will be extracted to ~/.kde4/share/apps/plasma/plasmoids/sk_lwp-15.0

You need to modify the file liquid_weather.py. In the method checkDependencies(widget), it tries importing qt libs, which for whatever reason fails. So comment (or remove) out the following (lines 3663-3668)

hey presto it all now works.

Hope it helps

RD - Aug 13 2008