Image 01
profile-image

einheitlix

Malte Skoruppa
Kroller

Karamba & Superkaramba by caspian 162 comments

First of all, let me say I simply love your widget! I'm so fond of that MacOS X style toolbar I actually decided to switch back from Xfce to KDE (and a few other things too, but it was one of the reasons) ;-) Thumbs up!

There are also very nice barimages and icons done by angelizer:
http://www.kde-look.org/content/show.php?content=13109
I added those to my kroller here (instead of using Skroller itself, because that is still based on kroller v0.94, and I prefer to keep up with the "original" kroller ;))
You might want to consider taking them into the "official" release, so they don't get lost...?

Anyway, what I really wanted to ask (I'm sorry if this already came up, but I really don't feel like reading through 14 pages of comments): the only thing that really disturbs me is that I have to double-click on the icons. Is this normal behaviour? Is there a way to have kroller reacting to just a single click? I know it's feasible with the Superkaramba API - other plugins like Aero AIO or LiquidWather react to single clicks, too. Maybe I'll have a look at it myself, but I first wanted to ask whether this is supposed to be like this or if there's an easy way to change that behaviour and I'm only overseeing something, before I dive into the code ;)


Thanks,
Malte - Apr 17 2007
Multi_Search

Karamba & Superkaramba by boralyl 32 comments

I like it, but it seems that it is impossible to add different engines that lie on the same server. I tried to add the english, french and spanish dict.leo.org, the search URLs are:

http://dict.leo.org/ende?search=$
http://dict.leo.org/frde?search=$
http://dict.leo.org/esde?search=$

However, after I added one of them, I cannot add others. Maybe because multi_search thinks they are the same and doesn't want to make double entries?

Notice also how, on those three different sites, the favicon.ico changes. multi_search always only retrieves the default one, which would make the three impossible to distinguish even if they could be added all three to the widget.

It would be nice to have support for this :-)
- Apr 15 2007
Liquid Amarok

Karamba & Superkaramba by lb10 14 comments

great job, although I had to fiddle around a bit with unzipping to the correct directories manually, otherwise the widget wouldn't find the themes... but no harm :-)

i'd very much like to see an "apply" button in the configuration menu. it's very annoying to have to click on "ok" each time when one changes something, because the config menu then disappears. so for example, when i wanted to try out all the themes, i had to reopen the dialog every time.
- Apr 15 2007
Aero AIO 0.9.1: sensors-HD temp monitor

Karamba & Superkaramba by franceloc 33 comments

First off, great plugin! Keep going!

There's a few things I'd like to see, though:

1. The configuration of the temps is too "static": not all people have the same sensors everywhere. It would be nicer to have it like in gkrellm: it detects all your sensors automatically, and you can choose which ones you want to read out and how you want to label them. I guess then it would also be better to use libsensors instead of just parsing the output of the sensors tool...

2. Because, on my system (gentoo), hddtemp is a root program (if i try to execute it as a user, it tells me "S.M.A.R.T. not available"), it lies in /usr/sbin/, which is not in the standard path of a user. So, for me, in AERO it always tells me 'hddtemp not found'. To get it working, I had to
- set the UID bit on /usr/sbin/hddtemp
- edit your tempmon_aio.py script, I had to change
hddtempCommand = ["hddtemp", self.hdd1TempTag]
to
hddtempCommand = ["/usr/sbin/hddtemp", self.hdd1TempTag]
to get it working.
Of course, it may not be in the same path for all distributions, but at least if it isn't found, you might want to add some code to check if it's in /sbin or /usr/sbin :-)
- Apr 15 2007
Aero AIO 0.9.1: sensors-HD temp monitor

Karamba & Superkaramba by franceloc 33 comments

Hi,

just out of curiosity: what is that "Power Temp" exactly? I ask because with my lm-sensors, by default I get three readings, temp1 through temp3, and I figured temp2 is the CPU and temp3 the M/B now, but I don't know what temp1 is. Most of the time it shows a temperature around 7°C... so maybe it's also some kind of "Power Temp"? But what does it mean?

- Apr 15 2007