Image 01
profile-image

husky

Friedemann Schorer
yaWP (Yet Another Weather Plasmoid)

Plasma 4 Extensions by PlasmaFactory 1198 comments

Hi udev,
thanks for your efforts, I appreciate.
I can confirm that r550 does build a DEB with proper dependencies, and it does install fine.
I built a DEB from r549 with a modified CMakeList.txt which had issues with files needing to be overwritten (dpkg -i --force-overwrite), and the DEB from r550 had the same problem today, but I can't tell if others may have the problem, too. As your build seemingly didn't have this glitch I may think it's a problem I caused myself...

Your script still makes the DEB depend on "kdebase-runtime (>= 4:4.9.00)" (note the double zero at the end) - can that be a problem for KDE SC 4.9.1?

Keep on coding! - Aug 24 2012
yaWP (Yet Another Weather Plasmoid)

Plasma 4 Extensions by PlasmaFactory 1198 comments

rev. 549 not working properly.

At least for Kubuntu PPA packages the kdelibs5 package has been split up into smaller ones, and my best guess (!) is to depend on kdelibs5-data. (Pls. note: I don't have any idea whether Debian will use the same packaging)

Other problem: The dependency is set to 4.9.00 - but the packages are version 4.9.0-0ubuntu2~precise1~ppa2 which is too low in terms of regexp. It should work with a single zero at the end instead of two. - Aug 19 2012
yaWP (Yet Another Weather Plasmoid)

Plasma 4 Extensions by PlasmaFactory 1198 comments

Hi all,
I tried to compile yawp for my laptop which has the Kubuntu Backports PPA packages for KDE SC 4.9 installed - it compiled fine, but the deb wasn't installable because of unmet dependencies.
Looking into the files I discovered that the dependencies for DEB files are set in ./CMakeLists.text.

In order to get a DEB for KDE 4.9 look into that file and adjust the following line:

Quote: SET(CPACK_DEBIAN_PACKAGE_DEPENDS "kdebase-runtime (>= 4:4.2.1), kdelibs5 (>= 4:4.2.1) | kdelibs5-data (>= 4:4.9), libc6 (>= 2.1.3), libgcc1 (>= 1:4.1.1), libplasma3, libqt4-dbus (>= 4.5.0~+rc1), libqt4-network (>= 4.5.0~+rc1), libqt4-svg (>= 4.5.0~+rc1), libqt4-xml (>= 4.5.0~+rc1), libqtcore4 (>= 4.5.0~+rc1), libqtgui4 (>= 4.5.0~+rc1), libstdc++6 (>= 4.2.1)")

Happy YAWPing, and thanks a lot for this nice applet! - Aug 16 2012
Tom des Tages

Plasma Comic Sources by chresan 7 comments

Well, I ain't got no idea how to get this into the comic script, but I got the solution. Find the script .kde/share/apps/plasma/comics/tom_des_tages/contents/code/main.es and edit it, so that it looks like this:

Quote: // search for the element: <img src="/dx/.1/gif.t,tom.d,1253311200" alt="TOM" width="560" />
// and extract the value of the src-attribute
var re = new RegExp("<img[\\s]+src=\"(/digitaz/.tom/gif.t,tom.d,[\\d]+)\"");

The first two lines are shown as a marker only, the third is the one you have to edit. After doing so the comics are displayed again.

Maybe someone can get this into the comic script so others can benefit, too? - Aug 31 2011
Tom des Tages

Plasma Comic Sources by chresan 7 comments

Hi!
Got quite a laugh the one day or the other through work, thx for that.
Some days ago the download of "Tom des Tages" failed continously - any ideas why?
Using Ubuntu Natty with KDE 4.7 from kubuntu.org here. Userfriendly and other comics still work.

PLs let me know how I may help you to track this down...

Friedemann - Aug 28 2011
PublicTransport

Plasma 4 Extensions by fpuelz 813 comments

(un-)installation on ubuntu works when one replaces "su" with "sudo" and removes the -c option and the quote signs around the command in that line, e.g.
Quote: sudo ./.scripts/helper_install.sh -u $installDataEnginePT -v $installDataEngineOSM -w $installAppletPT -x $installRunnerPT -y $installIconsPT -z $installTTMate -s $show_install_output - Jan 23 2011
PublicTransport

Plasma 4 Extensions by fpuelz 813 comments

sorry, I forgot: the link to the ubuntu package from AndiBauer doesn't work anymore, it should be removed. - Jan 23 2011
PublicTransport

Plasma 4 Extensions by fpuelz 813 comments

Hi!
Thanks for that applet. I'd really love to use your installer, but it filas in two ways:
- my ubuntu uses sudo by default, root password is not set - auth fails, somehow replacing 'su' with 'sudo' doesn't work so far
- it fails to detect that installation failed.

A very nice script which allows to compile things and build a distribution package automagically is provided with the YaWP-applet - maybe you can adapt that script a little? - Jan 23 2011
sexy

KDM4 Themes by gwydion-dot 12 comments

Great, thx for the quick reply.
hoping to see a fixed version soon :-D - Feb 20 2010
sexy

KDM4 Themes by gwydion-dot 12 comments

Hi!
Great pic, thx for doing that stuff.
Now that I have a 1280x800 screen, the login box (along with the words "username" and "password" are too near the borders, they're not shown completely.
How can Ichange that? I found the xml file, but I don't know which values to change...

I appreciate your kind answer! - Feb 11 2010
KNemo

Network by jstamp 805 comments

Just compiled 0.5.2 for my Kubuntu Hardy system without any problems and upgraded the old 0.5.1 - but now I can't see any traces of the app anywhere anymore :-( Although it worked like a charm with the 0.5.1 version I can't see any icons in the systray nor can I configure anything in systemssettings - the knemo entry isn't in the menu at all.

Any hints? KDE 4.2.2 here. Applying the patch in the above comment didn't change anything. - Apr 10 2009
Hi,
looks like you can add that searchenginge by hand as well:
open Konqueror
open Search-dropdown on the right, hit "Select search-engine"
hit "New"
enter:
Name: PubMed
Shortcut: http://www.ncbi.nlm.nih.gov/entrez/query.fcgi?db=PubMed&term=\{@}
Shortcut: pm,pubmed
Charset: utf8


Now activate PM as a search-engine and enter your searchterms into the field :D
(or "pm:" into Konquerors' address field) - Jan 08 2006
kio-locate

Various KDE 1.-4. Improvements by arminstraub 178 comments

Cool stuff, made my day :-D
Will this go into KDE CVS sometime? - Apr 02 2005