Image 01
profile-image

roderick

Roderick Greening
umm.. how long have you been using linux?

While the concept you envision is enviable, the way you present it is not possible. Multiple OS flavors require different libraries, etc., which are not guaranteed to be on each and every setup.

What RPM's, deb's, ebuilds, etc., try to accomplish are to set out the requirements for the software and ensure they are installed as without the requirements being met, the software will not run.

So, if you do not have GTK+ installed, and we try your method of instalation, firefox will never run.

Most will agree that there needs to be a ubiquitous install method or at least some common specification that defines the underlying rules for how to check for deps (something perhaps freedesktop.org or similar can help host/define).

Windows installers usially do one of 3 things:

1) Assume things will just work - most times they do not.
2) Re-copy anyand all DLL's that could be needed, evewn if they are older ones, which can render the system unusable after.
3) Perform some sanity checks, make proper backups, verify requirements ar emet, etc.

Even in these cases, windows will have multiple flavors 95, 98, XP, 2000, Millenium, and Vista. Not all software works the same across all of these, not do they use the same install software in all cases.

Anyway, a grand idea, however, I think you need to be a little more theoretical in your suggestion and do some additional research if you want to make a truely valuable contribution here.

Cheers. - Jul 05 2007
Icon execute feedback

Various KDE 1.-4. Improvements by dunkelstern 56 comments

I have applied the fix to the Xeffects overlay.

Only update appears to be in kdelibs, so xeffects users need only re-emerge kdelibs from overlay to get the fix.

http://www.gentoo-xeffects.org - Mar 07 2007
taskbar-compiz

Various KDE 1.-4. Improvements by kv11111 27 comments

This has been added to the Gentoo xeffects overlay (http://www.gentoo-xeffects.org) for anyone using Gentoo and is interesting in test driving.

I still have one or two ebuild issues to work out. See the forum post for more info: http://forums.gentoo-xeffects.org/viewtopic.php?f=14&t=377 - Feb 26 2007
Autostart Manager

Utilities by smileaf 43 comments

I was checking the code and did some research. It appears that X-KDE-autostart-condition is an entry that can be placed in a .desktop file, and allows one to check an rc file for additional conditions.

So, this could be a place to start looking for a "disable" feature by setting the condition in the rc file to false.

autostart would need to be modified to read/write out an rc file with the entry, add the disable option to the list, etc. Should be simple enough.

If I can make this work, I'll submit a patch for your perusal. - Feb 23 2007
Autostart Manager

Utilities by smileaf 43 comments

Is it possible to code a Disabled mode but leave the Autostart entry there?

I.e., say I am debugging some problem, and temporarily want to turn of some apps from autostarting, I select Disabled (rather than Startup/Shutdown/ENV) to allow me to test without having to permanently remove my autostart entry (and having to remember/re-create them again).

I think this would be useful, if easy enough to do.

Thoughts? - Feb 23 2007
Autostart Manager

Utilities by smileaf 43 comments

I see distro's are starting to include this in the packaging. That's great.

Perhaps it will become a part of KDE in the main trunk someday.

I have added the package to the xeffects overlay for Gentoo users. Further details at http://www.gentoo-xeffects.org.

Thanks. - Feb 23 2007
kio_resources

Various KDE 1.-4. Improvements by Linuster 28 comments

This is definitely a worthwhile KIO slave, and is even better than the locate:/ slave currently in Gentoo portage (at least for my purposes).

I have added this package to the xeffects overlay (see www.gentoo-xeffects.org for details) so more Gentoo users can enjoy.

Cheers. - Feb 23 2007
Icon execute feedback

Various KDE 1.-4. Improvements by dunkelstern 56 comments

I never tested under compiz/beryl...

Now, I just tested under beryl 0.1.9999.2 (X-effects overlay), and it works fine for me.

It is fast... but I definately get the animation frames. - Feb 22 2007
Icon execute feedback

Various KDE 1.-4. Improvements by dunkelstern 56 comments

Strange, I have an intel card and can see the animation fine... - Feb 19 2007
Icon execute feedback

Various KDE 1.-4. Improvements by dunkelstern 56 comments

Gentoo e-builds updated in xeffects overlay to version 0.3 - Feb 12 2007
Icon execute feedback

Various KDE 1.-4. Improvements by dunkelstern 56 comments

What is/are the bug fixes you are talking about. I'd like to integrate them as soon as possible.

Thanks - Feb 12 2007
Icon execute feedback

Various KDE 1.-4. Improvements by dunkelstern 56 comments

God I can't type... qapplication and not qtapplication.... - Feb 12 2007
Icon execute feedback

Various KDE 1.-4. Improvements by dunkelstern 56 comments

Sorry... typo in last message...

The addition was <qtapplication.h>. to kdelibs patch.

So, when you make your splits, please remember to add this in just before or after the <qpoint.h> insertion in the patch. - Feb 12 2007
Icon execute feedback

Various KDE 1.-4. Improvements by dunkelstern 56 comments

Hi,

I have integrated this into the Xeffects overlay for Gentoo if anyone is interested.

http://www.gentoo-xeffects.org/

The overlay can be added via the overlay tool layman. Check out the Xeffects wiki for details.

http://wiki.gentoo-xeffects.org/

These are done as split ebuilds, and in order to do so, I had to alter the kdelibs patch to insert in the header section. Otherwise, it was possible that kdelibs may not compile.

Cheers,
Rod. - Feb 12 2007
Digg.com plugin for Konqueror

Utilities by KDEfanboy 10 comments

I'm an idiot. Ignore the patch. It does not fix it.

Here's what I found.

If I click the home icon on desktop (it loads the Konqueror file browser profile) and then browse to a web site, all works as exected.

If I click on Konqueror icon (it loads the web browser profile) and this is where it is cut off and broken.

Any ideas? - Aug 17 2006
Digg.com plugin for Konqueror

Utilities by KDEfanboy 10 comments

Ignore previous...

It contained HTML chars and got hoofed in post.

Use this one...


--- konqplugin_digg/src/diggpluginwidgetbase.ui 2006-08-15 20:28:32.000000000 -0230
+++ konqplugin_digg/src/diggpluginwidgetbase.ui 2006-08-17 14:36:14.000000000 -0230
@@ -8,8 +8,8 @@
<rect>
<x>0</x>
<y>0</y>
- <width>343</width>
- <height>240</height>
+ <width>443</width>
+ <height>340</height>
</rect>
</property>
<property name="caption">
- Aug 17 2006
Digg.com plugin for Konqueror

Utilities by KDEfanboy 10 comments

I made the following patch and now I can see the buttons on the bottom correctly.

--- konqplugin_digg/src/diggpluginwidgetbase.ui 2006-08-15 20:28:32.000000000 -0230
+++ konqplugin_digg/src/diggpluginwidgetbase.ui 2006-08-17 14:36:14.000000000 -0230
@@ -8,8 +8,8 @@

0
0
- 343
- 240
+ 443
+ 340




Also need to add this to ebuild in a PATCHES line for the gentooers. - Aug 17 2006
Digg.com plugin for Konqueror

Utilities by KDEfanboy 10 comments

The floating Digg box appears cut off in my install. Any recommendations on how to fix? - Aug 17 2006
Digg.com plugin for Konqueror

Utilities by KDEfanboy 10 comments

Here's an ebuild for gentoo users:

# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $

inherit kde

DESCRIPTION="Digg.com Konqueror Plugin"
HOMEPAGE="http://www.kde-apps.org/content/show.php?content=44287"
SRC_URI="http://www.kde-apps.org/content/files/44287-konqplugin_digg.tar.bz2"
RESTRICT="nomirror"
LICENSE="GPL"
SLOT="0"
KEYWORDS="~x86"
IUSE=""
DEPEND=""
RDEPEND="${DEPEND}"

S="${WORKDIR}/konqplugin_digg"

need-kde 3.5
need-qt 3.6

src_compile () {
econf || die "configure failed"
cd ${S}/src
make libkonqplugin_digg.la
cd ${S}
emake || die "emake failed"
} - Aug 17 2006
logout dialog theme support and config tool

Various KDE 1.-4. Improvements by cjacker 18 comments

Ok,

I use Gentoo first of all, so I copied the existing ksnserver ebuild to my overlay and modded the ebuild to include the appropriate patch in your archive. emerged patched ksmserver 3.5.2 ok with patch.

Then, I made an ebuild for ksmtheme and successfuly built it and installed it.

Now, I go to Control Center, and KSM Theme shows up and it requires admin access to enable (probably should not as this should be per user unlike KDM manager which is legit to be system wide only).

So, I enter admin access and it allows me to enable the KSM and click on the everest theme. Apply is still greyed out and only option I have is OK.

CLick ok and then try and test. No change. I go back to KSM Theme and the enable box is empty again.

What is wrong here? - Apr 04 2006